Announcement

Collapse
No announcement yet.

No "download" button for game software

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No "download" button for game software

    I pre-ordered and I got an email saying that the guide was ready to be downloaded. I search my order and sure enough the guide has a "download" button underneath of it but the actual game software itself does not. I have called twice and they say that I will receive an email some time today saying that my software is ready to download. It seems like everyone else has access to their downloads- can anyone help me?!

  • #2
    Double check you didn't receive it, for me the guide was in the same email as the game if I recall correctly. Check your spam mail folder as well just in case it was sent there. Otherwise take a deep breath and give them some time. If by tomorrow its still not there then there's another issue.

    Comment


    • #3
      I had to search my order via my email address and credit card number and that was the ONLY way i saw a download button.
      Even when i check my order history its not even there.
      but even then mine isnt working (MAC)

      Comment


      • #4
        Same issue here. Pre-ordered back on Oct 15th. Got email today with download link for Strategy Guide PDF and that worked fine, but for the extended download service it just says 'Other', no link. Even in the invoice on Digital Rivers site it also just says 'Other'. Called them twice, they appear to know they have an issue. Sheez....
        Extended Download Service
        • Other

        Comment


        • #5
          Same thing is happening to me!! I've looked on my email several times, on the order, and tried to log in and they tell me my email address is invalid when it's the email I used on the order. I was planning on playing tomorrow!!! I hope I get another email soon with it.

          Comment


          • #6
            I have the resolution as it was the same issue I was having---- go to your order history page and click on your order number for MID. Now it brings you to the screen where the download button isn't working, correct? There is a phone number (actually 2 numbers--- don't use the 1-800 one, use the regular) and call it. I waited on hold for AT MOST 5 minutes but within two second of telling the guy my email/name/order # he asked me to refresh the page and it was solved!

            Happy Hunting!

            Comment

            Working...
            X